Message
"Unfortunately this program isn’t compatible with your setup. To watch, your 4K TV must be HDR capable."
Cause
The customer attempted to play a 4K HDR program, but the TV Box does not identify the connected TV as being a compatible 4K HDR TV.
To play 4K HDR content the customer must have a compatible 4K HDR TV with HDCP 2.2 compliant ports, the correct model(s) of TV box, the right resolution, and an HDMI cable that is also HDCP 2.2 compliant. The customer should refer to their TV manual to see if they can receive 4K HDR content.
Solution code
Your TV may not be compatible with viewing 4K HDR content. For more information on compatible 4K UHD equipment, select Learn More on the error message or see our requirements for viewing 4K UHD HDR content on X1.
If you continue to experience issues, please contact us using the method that is most convenient for you — chat with us online or call us to speak with a Comcast representative.